Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

Установка DAHDI

1

Всем привет. Возникла проблема с установкой DAHDI на виртуальном сервере (для meetme).

You do not appear to have the sources for the 2.6.18-194.8.1.el5.028stab070.5 ke                                                                                            rnel installed.

Гугл предложил установить linux-headers и build-essential. Сделал апдейт и вот что вышло:

apt-get install linux-headers-`uname -r`
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package linux-headers-2.6.18-194.8.1.el5.028stab070.5

apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.

Помогите пожалуйста, очень нужны конференции :)

удалить закрыть спам изменить тег редактировать

спросил 2011-07-08 00:30:31 +0400

blkang Gravatar blkang
71 9 4 14

Comments

виртуальный сервер ваш(вы предоставляете) или вы купили VPS? meral ( 2011-07-08 10:56:26 +0400 )редактировать
Не мой, купил blkang ( 2011-07-08 12:12:31 +0400 )редактировать

3 Ответа

1

Не мой, купил

тогда, если у вас поддержка астериска прямо не заявлена, вы ничего не добьетесь даже если удастся скомпилировать.

ибо по ядру у вас openvz. на такой архитектуре необходима установка dahdi на основном сервере, и разрешение вам использовать полученные устройства.

более того, если провайдер не гарантирует работу астериска, могут быть проблемы со звуком связанные с виртуализацией.

но вам ведь надо не скомпилировать, а получить конференцию, правда? используйте app_conference, она не требует dahdi.

зы. предлагаю vps с поддержкой asterisk/metmee, в германском DC.

ссылка удалить спам редактировать

ответил 2011-07-08 15:26:33 +0400

meral Gravatar meral flag of Ukraine
21228 24 19 169
http://pro-sip.net/

Comments

Спасибо. Проблема решена переходом с виртуальной на полную машину. Кстати, со сборкой app_conference и app_konference у меня тоже возникли проблемы. Нашел решение- confbrige. Удачи. blkang ( 2011-07-12 16:17:06 +0400 )редактировать
0

alexcr,

     apt-get install linux-headers
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package linux-headers is a virtual package provided by:
  linux-headers-2.6-amd64 2.6.39+35.1
  linux-headers-2.6.39-2-amd64 2.6.39-2
  linux-headers-2.6-xen-amd64 2.6.32+29
  linux-headers-2.6-vserver-amd64 2.6.32+29
  linux-headers-2.6-openvz-amd64 2.6.32+29
  linux-headers-2.6.32-5-xen-amd64 2.6.32-35
  linux-headers-2.6.32-5-vserver-amd64 2.6.32-35
  linux-headers-2.6.32-5-openvz-amd64 2.6.32-35
  linux-headers-2.6.32-5-amd64 2.6.32-35
You should explicitly select one to install.
E: Package linux-headers has no installation candidate
root@9533:~# apt-get install linux-headers-2.6-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libc-dev-bin: Depends: libc6 (> 2.13) but 2.11.2-11 is to be installed
  libc6: Depends: libc-bin (= 2.11.2-11) but 2.13-7 is to be installed
  libc6-dev: Depends: libc6 (= 2.13-7) but 2.11.2-11 is to be installed
  linux-headers-2.6-amd64: Depends: linux-headers-2.6.39-2-amd64 but it is not going to be installed
  locales: Depends: glibc-2.13-1
  locales-all: Depends: glibc-2.13-1
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@9533:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libc6
Suggested packages:
  glibc-doc
The following packages will be upgraded:
  libc6
1 upgraded, 0 newly installed, 0 to remove and 245 not upgraded.
6 not fully installed or removed.
Need to get 0B/4314kB of archives.
After this operation, 381kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
(Reading database ...
dpkg: warning: files list file for package `libc6' missing, assuming package has no files currently installed.

    (Reading database ... 33417 files and directories currently installed.)
Preparing to replace libc6 2.11.2-11 (using .../libc6_2.13-7_amd64.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...

A non-dpkg owned copy of the C library was found:
  '/lib/ld-2.11.2.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib' and try again.
dpkg: error processing /var/cache/apt/archives/libc6_2.13-7_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.13-7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
ссылка удалить спам редактировать

ответил 2011-07-08 12:34:53 +0400

blkang Gravatar blkang
71 9 4 14

обновил 2011-07-08 12:35:33 +0400

0
apt-get install linux-headers

apt-get install aptitude
aptitude search linux
ссылка удалить спам редактировать

ответил 2011-07-08 08:10:20 +0400

alexcr Gravatar alexcr
3124 10 9 51
http://asterisk-service.c...

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2011-07-08 00:30:31 +0400

Просмотрен: 2,020 раз

Обновлен: Jul 08 '11

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.