Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

* и E171 huawei отваливается при звонке

1
привет всем 
   Есть * 1.8 ubuntu и модем E171 huawei 
chan_datacard собрался нармально 
Код:

asterisk*CLI> datacard show devices 
ID           Group State      RSSI Mode Submode Provider Name  Model      Firmware          IMEI             IMSI             Number        
datacard1    2     Free       11   0    0       MTS-RUS        E171       11.126.85.01.143  354807040887861  250018360009777  Unknown    


и 

Скрытый текст

asterisk*CLI> datacard show device state datacard1 
-------------- Status ------------- 
Device : datacard1 
State : Free 
Audio : /dev/ttyUSB1 
Data : /dev/ttyUSB2 
Voice : Yes 
SMS : Yes 
Manufacturer : huawei 
Model : E171 
Firmware : 11.126.85.01.143 
IMEI : 354807040887861 
IMSI : 250018360009777 
GSM Registration Status : Registered, home network 
RSSI : 11, -119 dBm 
Mode : No Service 
Submode : No service 
Provider Name : MTS-RUS 
Location area code : DDE0 
Cell ID : 223 
Subscriber Number : Unknown 
SMS Service Center : +79104999109 
Use UCS-2 encoding : Yes 
USSD use 7 bit encoding : No 
USSD use UCS-2 decoding : No 
Tasks in queue : 0 
Commands in queue : 0 
Call Waiting : Enabled 
Current device state : start 
Desired device state : start 
Calls/Channels : 0 
Active : 0 
Held : 0 
Dialing : 0 
Alerting : 0 
Incoming : 0 
Waiting : 0 
Releasing : 0 
Initializing : 0 





ну и ext 

Код:
[CallingRule_GSM] 
exten = _X.,1,Dial(Datacard/datacard1/${EXTEN})


Призвонке с софтфона все накрывается мед тазиком (( 


вот что пишет 
Скрытый текст

[Apr 22 11:37:20] ERROR[3553]: chan_datacard.c:400 do_monitor_phone: [datacard1] Lost connection to Datacard 
asterisk*CLI> datacard show devices 
ID Group State RSSI Mode Submode Provider Name Model Firmware IMEI IMSI Number 
datacard1 2 Not connec 0 0 0 NONE Unknown 
[Apr 22 11:37:27] ERROR[3631]: at_response.c:380 at_response_error: [datacard1] Error setting operator select parameters 
asterisk*CLI> datacard show device state datacard1 
-------------- Status ------------- 
Device : datacard1 
State : Not connected Start scheduled 
Audio : /dev/ttyUSB1 
Data : /dev/ttyUSB2 
Voice : No 
SMS : No 
Manufacturer : 
Model : 
Firmware : 
IMEI : 
IMSI : 
GSM Registration Status : Unknown 
RSSI : 0, <= -125 dBm 
Mode : No Service 
Submode : No service 
Provider Name : NONE 
Location area code : 
Cell ID : 
Subscriber Number : Unknown 
SMS Service Center : 
Use UCS-2 encoding : No 
USSD use 7 bit encoding : No 
USSD use UCS-2 decoding : No 
Tasks in queue : 0 
Commands in queue : 0 
Call Waiting : Disabled 
Current device state : stop 
Desired device state : start 
Calls/Channels : 0 
Active : 0 
Held : 0 
Dialing : 0 
Alerting : 0 
Incoming : 0 
Waiting : 0 
Releasing : 0 
Initializing : 0 

asterisk*CLI> 





Но через сек 20 вот что выдает типа модем готов 



Скрытый текст

[Apr 22 11:37:42] NOTICE[3635]: at_response.c:1078 at_response_ccwa: Call waiting is enabled on device datacard1 
asterisk*CLI> datacard show devices 
ID Group State RSSI Mode Submode Provider Name Model Firmware IMEI IMSI Number 
datacard1 2 Free 10 0 0 MTS-RUS E171 11.126.85.01.143 354807040887861 250018360009777 Unknown 
asterisk*CLI> datacard show device state datacard1 
-------------- Status ------------- 
Device : datacard1 
State : Free 
Audio : /dev/ttyUSB1 
Data : /dev/ttyUSB2 
Voice : Yes 
SMS : Yes 
Manufacturer : huawei 
Model : E171 
Firmware : 11.126.85.01.143 
IMEI : 354807040887861 
IMSI : 250018360009777 
GSM Registration Status : Registered, home network 
RSSI : 10, -119 dBm 
Mode : No Service 
Submode : No service 
Provider Name : MTS-RUS 
Location area code : DDE0 
Cell ID : 90223 
Subscriber Number : Unknown 
SMS Service Center : +79104999109 
Use UCS-2 encoding : Yes 
USSD use 7 bit encoding : No 
USSD use UCS-2 decoding : No 
Tasks in queue : 0 
Commands in queue : 0 
Call Waiting : Enabled 
Current device state : start 
Desired device state : start 
Calls/Channels : 0 
Active : 0 
Held : 0 
Dialing : 0 
Alerting : 0 
Incoming : 0 
Waiting : 0 
Releasing : 0 
Initializing : 0 

asterisk*CLI> 



Вчем может быть затык??? 
datacard 


Код:

[datacard1] 
context=datacard-incoming   ; context for incoming calls 
audio=/dev/ttyUSB1      ; tty port for audio connection 
data=/dev/ttyUSB2      ; tty port for AT commands 
group=2            ; calling group 
rxgain=3         ; increase the incoming volume 
txgain=3         ; increase the outgoint volume 
autodeletesms=yes      ; auto delete incoming sms 
resetdatacard=yes      ; reset datacard during initialization 
u2diag=0         ; set U2DIAG parameter (0 = disable everything except modem function) 
usecallingpres=yes      ; use the caller ID presentation or not 
callingpres=allowed_passed_screen ; set caller ID presentation 



вывод ls 

Код:

ls /dev |grep USB 
ttyUSB0 
ttyUSB1 
ttyUSB2
удалить закрыть спам изменить тег редактировать

спросил 2011-04-25 07:28:33 +0400

avolon Gravatar avolon
9 22 2 15

9 Ответов

0

Все заработало но надругой машине (((Почему хз!!

ссылка удалить спам редактировать

ответил 2011-04-26 09:13:07 +0400

avolon Gravatar avolon
9 22 2 15

Comments

lsusb на первой и второй машине zlat ( 2011-04-26 09:45:55 +0400 )редактировать
0

Смотрел но чет не могу найти там прошивку для e171

ссылка удалить спам редактировать

ответил 2011-04-25 15:37:14 +0400

avolon Gravatar avolon
9 22 2 15
0

E171 в руках не держал но эксперементировал с E1550 E150 и E1750. Так вот, столкнулся с похожей ситуацией. Проблема была в версии прошивки модема. На сайте и доках DATACARD есть упомининия что некоторые типы прошивок (номера не помню поищите сами) не работают с DATACARD. После того как нашел "правильные" прошивки и перепрошил модемы у меня все заработало нормально.

Про номера прошивок можно посмотреть здесь http://www.asterisk-pbx.ru/wiki/doku.php/new2

ссылка удалить спам редактировать

ответил 2011-04-25 09:23:41 +0400

romanmalyutin Gravatar romanmalyutin
1 1 2
http://www.palladagroup.r...

обновил 2011-04-25 10:32:48 +0400

Comments

Скорее всего дело в прошивке, у меня такая же проблема была. Причем звонки делались даже на 2.6.26 ядре, но не более 20 секунд. Потом нарыл статейку (указана выше), обновился и все заработало. Ecuador ( 2011-04-27 08:22:04 +0400 )редактировать
0

Вообче то правда на той странице не упоминается прошивка для этого модема. У меня есть модем Е1750. Для него подошла прошивка 11.126.08.01.00 Нашел ее на каком то буржуйском сайте. На каком не подскажу. Давно было. Перепробовал штук пять прошивок. Эта заработала. Ваш модем У171 похоже из этой же серии. Попробуйте может подойдет.

ссылка удалить спам редактировать

ответил 2011-04-28 20:10:24 +0400

romanmalyutin Gravatar romanmalyutin
1 1 2
http://www.palladagroup.r...
0

Использую Е 1550 видел сначала аналогичную ситуацию. Использую 3 модема одновременно. После некоторых эксперементов обнаружил что модемы надо подключать через шнурки, обычные usb-удлинители (желательно серебристые), кстатий это же рекомендавали ребята которые продавали модемы. На сегодня стабильно работает 4-ре модема.

ссылка удалить спам редактировать

ответил 2012-03-27 00:03:57 +0400

Leshiy Gravatar Leshiy
6 1 5

обновил 2012-03-27 00:05:19 +0400

0

Попробуй chan_dongle вместо datacard поставить.
Он чуток посвежее!

ссылка удалить спам редактировать

ответил 2012-03-29 06:27:06 +0400

bolshoy_plohish Gravatar bolshoy_plohish
1358 21 16 37
0

Все дело в питание модема, поэтому и работает на другой нормальной машине :)
Тут много раз поднимался вопрос питания и использование модема через USB switch.

ссылка удалить спам редактировать

ответил 2011-04-27 08:28:35 +0400

alexcr Gravatar alexcr
3124 10 9 51
http://asterisk-service.c...

Comments

именно, нужно просто врубать через нормальный активный хаб. Еще сейчас появились матери с поддержкой iPhone/iPad - с увеличенным допустимым током на портах USB.

Zavr2008 ( 2012-03-27 11:57:16 +0400 )редактировать
0

171 свистки с прошивками 11.126.85.01.143 11.126.16.12.143

сначала всё работало около недели - двух, сейчас при исходящем отваливается свисток, потом подключается опять. вроде ничего не делал особо. на роутер с астериском устанавливал трансмиссион и скайп, питание не причем, прошивка походу тоже ибо работало

ссылка удалить спам редактировать

ответил 2012-03-12 21:07:10 +0400

immortal Gravatar immortal
1
0

171 свистки с прошивками 11.126.85.01.143 11.126.16.12.143

сначала всё работало около недели - двух, сейчас при исходящем отваливается свисток, потом подключается опять. вроде ничего не делал особо. на роутер с астериском устанавливал трансмиссион и скайп, питание не причем, прошивка походу тоже ибо работало

ссылка удалить спам редактировать

ответил 2012-03-12 21:07:36 +0400

immortal Gravatar immortal
1

Comments

щас прийдет телепат и скажет в чем у вас проблема.

meral ( 2012-03-12 21:44:38 +0400 )редактировать

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку
1 закладка

подписаться на rss ленту новостей

Статистика

Задан: 2011-04-25 07:28:33 +0400

Просмотрен: 4,713 раз

Обновлен: Mar 29 '12

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.