Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

VoIP неудовлетворительное качество связи (результаты тестирования канала iperf)

0

Доброго времени суток!

Прошу помощи, в выявлении причин неудовлетворительного качества связи через VoIP.

схема: (asterisk)<->(freeswitch)<--100mbit/s-->((internet))<--10mbit/s-->(mikrotik_RB950)<->(PC, Twinkle)

PC находятся за натом, freeswitch имеет паблик-ip. На момент тестирования на mikrotik'е выполнен проброс порта в сторону PC. 256K ширана полосы выбрана в iperf для того, чтобы не нагружать и так маленький канал.

Результаты тестирования в сторону PC от FreeSwitch'а:

iperf -u -c %%MIKROTIKPUBIP%% -b 256K -p 602 -l 200 -t300

Client connecting to %%MIKROTIKPUBIP%%, UDP port 602

Sending 200 byte datagrams

UDP buffer size: 224 KByte (default)

[ 3] local %%FRSWITCHPUBIP%% port 59681 connected with %%MIKROTIKPUBIP%% port 602

[ ID] Interval Transfer Bandwidth

[ 3] 0.0-300.0 sec 9.16 MBytes 256 Kbits/sec

[ 3] Sent 48001 datagrams

[ 3] Server Report:

[ 3] 0.0-300.0 sec 9.16 MBytes 256 Kbits/sec 0.388 ms 2/48001 (0.0042%)

Собственно вопрос #1: jitter 0.388 ms - это означает менее одной милисекунды или 388ms? Кол-во потерь я так понимаю подходит под стандарт <1 %.

Клиенты жалуются на плохую слышимость (т.е. прохождение пакетов от freeswitch до PC)

Попытки настроить QoS на mikrotik'е не дали какого-либо результата в положительную сторону, хотя очереди работают. Настраивал так:

/ip firewall mangle

add action=mark-packet chain=forward disabled=no passthrough=yes new-packet-mark=def src-address=!<mikrotik_public_ip>

add action=mark-packet chain=forward disabled=no passthrough=yes dst-address=!<mikrotik_public_ip> new-packet-mark=def

add action=mark-packet chain=forward disabled=no passthrough=yes new-packet-mark=voip src-address=<mikrotik_public_ip>

add action=mark-packet chain=forward disabled=no passthrough=yes dst-address=<mikrotik_public_ip> new-packet-mark=voip

/queue tree

add disabled=yes max-limit=9M name=in parent=global

add disabled=yes max-limit=2M name=def packet-mark=def parent=in

add disabled=yes limit-at=6M max-limit=7M name=voip packet-mark=voip parent=in priority=1

image description

Результат теста с QoS:

iperf -u -c %%MIKROTIKPUBIP%% -b 256K -p 602 -l 200 -t300


Client connecting to %%MIKROTIKPUBIP%%, UDP port 602

Sending 200 byte datagrams

UDP buffer size: 224 KByte (default)


[ 3] local %%FRSWITCHPUBIP%% port 43811 connected with %%MIKROTIKPUBIP%% port 602

[ ID] Interval Transfer Bandwidth

[ 3] 0.0-300.0 sec 9.16 MBytes 256 Kbits/sec

[ 3] Sent 48001 datagrams

[ 3] Server Report:

[ 3] 0.0-300.0 sec 9.15 MBytes 256 Kbits/sec 0.433 ms 11/48001 (0.023%)

Прошу помощи, в решении вопроса. Уже незнаю куда копать(

Заранее огромное спасибо!

удалить закрыть спам изменить тег редактировать

спросил 2015-03-24 16:04:06 +0400

Yurii Gravatar Yurii
1 1 1

обновил 2015-03-24 16:06:47 +0400

Comments

с public-ip фрисвитча iperf коннектится на порт 602 mikrotika который в свою очередь пробрасывает пакеты вовнутрь сетки на операторский ПК

Yurii ( 2015-03-24 17:05:07 +0400 )редактировать

советую записать pcap звонка, затем через RTP Analyzer в Wireshark посмотреть параметры. Там важно не только кол-во losses, но также и параметры skew и jitter.

Zavr2008 ( 2015-03-24 21:43:43 +0400 )редактировать

Выложите в топик скрин анализатора..

Zavr2008 ( 2015-03-24 21:44:06 +0400 )редактировать

1 Ответ

1

какой вы недоверчивый. 0.3мс это никак не 0.3 секунды.

мерять надо на порту где у вас rtp. зачем вы меряете на 602м порту?

ссылка удалить спам редактировать

ответил 2015-03-24 16:30:13 +0400

meral Gravatar meral flag of Ukraine
21228 24 19 169
http://pro-sip.net/

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку
1 закладка

подписаться на rss ленту новостей

Статистика

Задан: 2015-03-24 16:04:06 +0400

Просмотрен: 301 раз

Обновлен: Mar 24 '15

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.