Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

gs1002 паузе перед отправкой звонка на Asterisk

0

При входящем звонке на GS1002 проходит 2-4 гудка и только потом звонок уходит на астериск. Подскажите пожалуйста, в какую сторону смотреть чтобы минимизировать это время к минимуму?

конфиг аддпака:

Current configuration:
!
version 8.51.008
!
hostname GS1002
!
username root password router administrator
username guest password guest user
!
!
interface Loopback0
 ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
 ip address 192.168.10.5 255.255.255.0
 ip nat outside
 speed auto
 no qos-control
!
interface FastEthernet0/1
 ip address 192.168.11.5 255.255.255.0
 ip nat inside
 speed auto
 no qos-control
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1 10
!
access-list 100 permit ip 192.168.11.0 0.0.0.255 any
!
!
ip nat inside source list 100 interface FastEthernet0/0  overload
!
!
!         
http server
!
dns name-server 192.168.10.1
logging command
logging event 4-warning
logging on
! 
! 
! 
! 
! VoIP configuration. 
! 
! 
! Voice service voip configuration. 
! 
voice service voip 
 protocol sip
 dtmf-relay out-of-band
 fax protocol t38 redundancy 0 
 fax rate 9600 
 h323 call start fast 
 h323 call tunnel enable 
 no call-barring unconfigured-ip-address
 no voip-inbound-call-barring enable
! 
! 
! Voice port configuration. 
! 
! GSM 
voice-port 0/0 
 connection plar 201 
 dial-tone-generate 
 caller-id enable
!         
! 
! GSM 
voice-port 0/1 
 connection plar 202 
 dial-tone-generate 
 caller-id enable 
! 
! 
! 
! 
! service port group configuration. 
! 
! 
! 
! Pots peer configuration. 
! 
dial-peer voice 1 pots
 destination-pattern 01T 
 port 0/0 
 user-name gsm1 
 user-password gsm1 
 translate-outgoing called-number 1 
! 
dial-peer voice 2 pots
 destination-pattern 02T 
 port 0/1 
 user-name gsm2 
 user-password gsm2 
 translate-outgoing called-number 2 
! 
! 
! 
! Voip peer configuration.
!         
dial-peer voice 0 voip 
 destination-pattern T 
 session target sip-server  
 session protocol sip 
 voice-class codec 1 
 no vad
 dtmf-relay rtp-2833 
! 
! 
! 
dial-peer call-hold h 
! 
dial-peer hunt 2 
! 
! 
gatekeeper
! 
! 
! Gateway configuration. 
! 
gateway 
 h323-id voip.192.168.10.5 
 no ignore-msg-from-other-gk 
! 
! 
! Codec classes configuration. 
! 
voice class codec 1 
 codec preference 1 g711alaw 
 codec preference 2 g711ulaw 
 codec preference 3 g729 
! 
!
!         
! Translation Rule configuration. 
! 
translation-rule 1 
 rule 0      01T                      T                                
! 
translation-rule 2 
 rule 0      02T                      T                                
!                               
! 
! 
! 
! SIP UA configuration. 
! 
sip-ua 
 user-register 
 sip-server 192.168.10.1 
 called-party-number to-field
 remote-party-id 
 register e164 
! 
! 
! Tones 
!
! 
! 
! 
! SMTP sendmail configuration 
!
sms-delivery 
! 
! 
!
line console
!
line vty
!
mobile dev-restart-by-unreg 300
!
mobile 0/0
 gsm sms-language utf8
!
mobile 0/1
 gsm sms-language utf8
!
end

вот что пишет debug

GS1002# [170926.034] MOBILE-0/0: RING
209     <CEP    000000> : Call Received 
[170926.040] MOBILE-0/0: CLIP (+790681....)

-----> здесь несколько гудков


GS1002# 210     <SIP    12737>  : Set Terminated Success for 12737 REGISTER
211     <SIP    12738>  : Set Terminated Success for 12738 REGISTER
[170931.049] MOBILE-0/0: RING
212     <CEP    000000> : Call Received 
213     <CEP    000000> : Call Initiated : calledNumber() crv(0) total(0)
214     <Call   257>    : ******  Call Created status(InitiatedByMobile) ver(8.51:2011-02-06-00-00) time(1365716526) ****  
215     <CEP    000000> : Decode CID : FFFFFF80  E 10  C 2B 37 39 3.... 
216     <CEP    000000> : Mobile CID : time() callingNumber(790681....) callingName()
217     <CEP    000000> : Calling number(7906....)
218     <CEP    000000> : Call id(2e2e6751-761d-b221-81a7-0002a408d29c) callNum(257)
219     <Call   257>    : MatchAllProcess After Sorted
                          <0>  id(0) dest(T) prefer(0) selected(82)
220     <Call   257>    : Initiate callee with dial-peer(T) status(CalleeDeterminedAll) id(2e2e6751-761d-b221-81a7-0002a408d29c) 
221     <NetEP  257>    : InitiateOutCall: calledNum(201) callingNum(79068....) target(sip-server)
222     <NetEP  257>    : DoCall: calledAddr(sip:201@192.168.....:5060) callingAddr(79068....)
[170931.052] MOBILE-0/0: CLIP (+79068....)
223     <SIP    257>    : SetLocalAudioFormats : outbound(TRUE) hqaEnable(FALSE) 
224     <SIP    257>    : SetLocalAudioFormats : myVoipPeer(0) is not NULL, voiceCodecClass(1)
225     <SIP    257>    : SetLocalAudioFormats : outbound(TRUE) hqaEnable(FALSE) 
226     <SIP    257>    : SetLocalAudioFormats : myVoipPeer(0) is not NULL, voiceCodecClass(1)
227     <SIP    0>      : No authentication information available 
228     <SIP    257>    : Send INVITE Request 
229     <SIP    257>    : Receive 100 Trying
230     <SIP    257>    : Transaction (152 INVITE) proceeding 
231     <SIP    257>    : Receive 200 OK
232     <SIP    257>    : Received INVITE OK response 
233     <SIP    257>    : Send ACK Request 
234     <SIP    257>    : SetLocalAudioFormats : outbound(TRUE) hqaEnable(FALSE) 
235     <SIP    257>    : SetLocalAudioFormats : myVoipPeer(0) is not NULL, voiceCodecClass(1)
236     <SIP    257>    : Get SIP Audio MediaFormat : 8 
237     <Call   257>    : Connected from(fffffffe)
удалить закрыть спам изменить тег редактировать

спросил 2013-04-09 17:56:13 +0400

semenoveg Gravatar semenoveg
1 1 1

обновил 2013-04-11 16:49:10 +0400

Comments

добавил вывод дебага debug mobile all-ports call debug voip call

semenoveg ( 2013-04-11 16:49:48 +0400 )редактировать

пробовал убирать dial-tone generate после перезагрузки вновь появляются эти строки

semenoveg ( 2013-04-15 10:38:44 +0400 )редактировать

2 Ответа

0
debug gsm all-ports call
debug voip call

Изучайте логи, смотрите какое время проходит между входящим gsm звонком и исходящим звонком в voip. Возможно, причина не в аддпаке, а в сети оператора...

ссылка удалить спам редактировать

ответил 2013-04-10 01:19:52 +0400

Olpag Gravatar Olpag
1884 3 4 29
0

dial-tone generate пробовали убрать? gs1002-1004 без него у меня работают шустро.

ссылка удалить спам редактировать

ответил 2013-04-15 09:52:14 +0400

tesak89 Gravatar tesak89 flag of Russian Federation
292 23 1 11

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку
1 закладка

подписаться на rss ленту новостей

Статистика

Задан: 2013-04-09 17:56:13 +0400

Просмотрен: 207 раз

Обновлен: Apr 15 '13

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.