Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

Elastix + addpac GS1001 не проходят входящие

1

Добрый день!
пытаюсь подружить addpac gs1001, исходящие проходят а вот входящие почему то нет

конфиг addpac

!
! APOS(tm) configuration saved from vty
!  2011/11/04 15:57:10 
!
version 8.51.002
!
hostname GS1001
!
username root password router administrator
username guest password guest user
!
!
interface Loopback0
 ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
 ip address 192.168.0.160 255.255.255.0
 speed auto
 no qos-control
!
interface FastEthernet0/1
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 speed auto
 no qos-control
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1 10
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
!
!
ip nat inside source list 100 interface FastEthernet0/0  overload
!
!
!
ftp server
http server
!
dns name-server 192.168.0.1
logging command
logging event 4-warning
logging on
! 
! 
! 
! 
! VoIP configuration. 
! 
! 
! Voice service voip configuration. 
! 
voice service voip
 protocol sip
 dtmf-relay rfc-2833
 fax protocol t38 redundancy 0
 fax rate 9600
 h323 call start fast
 h323 call tunnel enable
 no call-barring unconfigured-ip-address
  call-barring allow-ip 192.168.0.150
 voip-inbound-call-barring enable
 voip-inbound-call-barring allow-digits 11 11
!
!
! Voice port configuration.
!
! GSM
voice-port 0/0
 connection plar 480707
 caller-id enable
!
! service port group configuration.
!
! Pots peer configuration.
!
dial-peer voice 1 pots
 destination-pattern T
!
dial-peer voice 900 pots
 destination-pattern 8T
 port 0/0
 no register e164
!
!
!
! Voip peer configuration.
!
dial-peer voice 10100 voip
 destination-pattern [0-79]T
 session target sip-server
 session protocol sip
 voice-class codec 0
 no vad
 dtmf-relay rtp-2833
!
!
gatekeeper
!
!
! Gateway configuration.
!
gateway
 h323-id voip.192.168.0.150
 no ignore-msg-from-other-gk
!
!
! Codec classes configuration.
!
voice class codec 0
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
!
! SIP UA configuration.
!
sip-ua
sip-server 192.168.0.150
 hook-flash-info-ignore
!
!
! Tones
!
line console
!
line vty
!
gsm dev-restart-by-unreg 300
!
gsm 0/0
 sms-language utf8
!
end

конфиг elastix

trunk 480707
type=friend
call-limit=1
host=192.168.0.160
port=5060
fromdomain=192.168.0.160
nat=no
qualify=yes
canreinvite=no
insecure=port,invite
dtmfmode=auto
dial=SIP/101
context=from-pstn
disallow=all
allow=alaw&ulaw

контекст user

type=friend
context=from-pstn
host=192.168.0.160
dtmfmode=auto

лог addpac

GS1001# 1       <CEP    000000> : Call Received
2       <CEP    000000> : Call Received
3       <CEP    000000> : Call Initiated : calledNumber() crv(0) total(0)
4       <Call   2>      : ******  Call Created status(InitiatedByGSM) ver(8.28:2
006-02-06-00-00) time(1320499139) ****
5       <CEP    000000> : Decode CID : FFFFFF80  E 10  C 2B 37 39 35 31 34 32 30 36 30 36 31
6       <CEP    000000> : GSM CID : time() callingNumber(79514206061) callingName()
7       <CEP    000000> : Calling number(79514206061)
8       <CEP    000000> : Call id(c337b54e-03a1-6eec-8003-0002a40847c4) callNum(2)
9       <Call   2>      : MatchAllProcess After Sorted
                          <0>  id(10100) dest([0-79]T) prefer(0) selected(1)
                          <1>  id(1) dest(T) prefer(0) selected(0)
10      <Call   2>      : Terminated from(fffffff7) this(Local:ResourceUnavailable) before((null)) forced(0) time(1320499139)
11      <CEP    000000> : DisconnectCall at Busy
12      <CEP    000000> : StopSignal
13      <CEP    000000> : Disconnect (0)
14      <Call   2>      : Terminated from(fffffff7) this(Local:Unknown) before(Local:ResourceUnavailable) forced(0) time(1320499139)
15      <CEP    000000> : Disconnected(16) at Disconnecting
удалить закрыть спам изменить тег редактировать

спросил 2011-11-05 10:27:11 +0400

annadiz85 Gravatar annadiz85
11 4 5

обновил 2011-11-05 10:50:00 +0400

alexcr Gravatar alexcr
3124 10 9 51
http://asterisk-service.c...

1 Ответ

1

Вот тут посмотри.
Ты hotline не поставил.

ссылка удалить спам редактировать

ответил 2011-11-05 10:55:30 +0400

alexcr Gravatar alexcr
3124 10 9 51
http://asterisk-service.c...

Comments

Спасибо выручил!!!! Еще вопрос входящие проходят почему то не стабильно

<2> Nov 5 14:11:25 local 79514206061 89509585717 : 0 Local:ResourceUnavailable
<1> Nov 5 14:11:11 outgoing 79514206061 895095XXXXX sip:895095XXXXX@19:192.168.0.150 Nov 5 14:11:02 9 Local:CallClear

делаю второй звонок и он так и остается на шлюзе на PBX не хочет идти... делаю третий все проходит... может это особенность этой железяки???

annadiz85 ( 2011-11-05 11:16:30 +0400 )редактировать

Думаю карта не успевает обратно к сети подцепится, попробуй band указать не auto а 800-1900 кажись такое там есть. Еще отметь как правильный ответ мой :)

alexcr ( 2011-11-07 23:28:17 +0400 )редактировать

dial-peer voice 1 pots - удали

Master135 ( 2011-11-08 11:08:10 +0400 )редактировать

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2011-11-05 10:27:11 +0400

Просмотрен: 1,117 раз

Обновлен: Nov 05 '11

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.