Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

AddPac Все звонки от одного ClID

0

На астер заведены 8 пользователей с двух шлюзов - AddPac AP700 (109-112) и AudioCodes (101-104). С AudioCodes проблем нет, а вот с аддпаки все вызовы приходят от юзера 109. Понять бы куда копать.

[general]
subscribemwi=no
language=ru
nat=no
format=wav
videosupport=yes
dtmfmode=auto
relaxdtmf=yes
limitonpeers=yes
bindaddr=0.0.0.0
rtpkeepalive=5
limitonpeer=yes
bindport=5060
;bindport=5061
allowguest=no
alwaysauthreject=yes
accept_outofcall_message=yes
outofcall_message_context=messages
auth_message_requests=no


[101]
type=friend
secret=000000
context=outgoing
host=dynamic
pickupgroup=1
callgroup=1
insecure=port,invite
canreinvite=no
nat=force_rport,comedia
dtmfmode=auto
qualify=yes
language=ru
disallow=all
allow=ulaw
allow=alaw

[102]
type=friend
secret=000000
;callerid=
pickupgroup=1
callgroup=1
context=outgoing
host=dynamic
insecure=port,invite
canreinvite=no
nat=force_rport,comedia
dtmfmode=auto
qualify=yes
language=ru
disallow=all
allow=ulaw
allow=alaw

[103]
type=friend
secret=000000
pickupgroup=1
callgroup=1
context=outgoing
;callerid=
host=dynamic
insecure=port,invite
canreinvite=no
nat=force_rport,comedia
dtmfmode=auto
qualify=yes
language=ru
disallow=all
allow=ulaw
allow=alaw

[104]
type=friend
secret=000000
pickupgroup=1
callgroup=1
context=outgoing
host=dynamic
insecure=port,invite
canreinvite=no
nat=force_rport,comedia
dtmfmode=auto
qualify=yes
language=ru
disallow=all
allow=ulaw
allow=alaw

[109]
type=friend
secret=000000
pickupgroup=1
callgroup=1
context=outgoing
host=dynamic
insecure=port,invite
canreinvite=no
nat=force_rport,comedia
dtmfmode=auto
qualify=yes
language=ru
disallow=all
allow=ulaw
allow=alaw

[110]
type=friend
secret=000000
pickupgroup=1
callgroup=1
context=outgoing
host=dynamic
insecure=port,invite
canreinvite=no
nat=force_rport,comedia
dtmfmode=auto
qualify=yes
language=ru
disallow=all
allow=ulaw
allow=alaw

[111]
type=friend
secret=000000
pickupgroup=1
callgroup=1
context=outgoing
host=dynamic
insecure=port,invite
canreinvite=no
nat=force_rport,comedia
dtmfmode=auto
qualify=yes
language=ru
disallow=all
allow=ulaw
allow=alaw

[112]
type=friend
secret=000000
pickupgroup=1
callgroup=1
context=outgoing
host=dynamic
insecure=port,invite
canreinvite=no
nat=force_rport,comedia
dtmfmode=auto
qualify=yes
language=ru
disallow=all
allow=ulaw
allow=alaw

Конфиг самой адпаки:

!
! APOS(tm) configuration saved from vty
!  2019/01/11 16:37:44 !
version 8.41.086
!
hostname AP700
!
username root password router administrator
username guest password guest user
!
!
interface Loopback0
 ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.241 255.255.255.0
 speed auto
 no qos-control
!
interface FastEthernet0/1
 no ip address
 speed auto
 no qos-control
!
interface FastEthernet0/1:1
 ip address 192.168.10.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1 10
!
!
!
ip dhcp pool default
 network FastEthernet0/1
  range FastEthernet0/0
!
!
dhcp server 
http server
!
dns name-server 77.88.8.8
ip connect default inside FastEthernet0/1 outside FastEthernet0/0
!
! 
! 
! 
! 
! VoIP configuration. 
! 
! 
! Voice service voip configuration. 
! 
protocol sip
dtmf-relay in-band
voice service voip 
 fax protocol t38 redundancy 0 
 fax rate 9600 
 h323 call start fast 
 h323 call tunnel enable 
 busyout monitor gatekeeper 
 busyout monitor sip-server 
 no busyout monitor callagent 
 busyout monitor voip-interface 
! 
! 
! Voice port configuration. 
! 
! FXS 
voice-port 0/0 
 caller-id enable 
! 
! 
! FXS 
voice-port 0/1 
 caller-id enable 
! 
! 
! FXS 
voice-port 0/2 
 caller-id enable 
! 
! 
! FXS 
voice-port 0/3 
 caller-id enable 
! 
! 
! 
! 
! Pots peer configuration. 
! 
dial-peer voice 1000 pots
 destination-pattern 109 
 port 0/0 
 user-password  EYEuHs6PTg5yZ3oUaQP5+g== encrypt
 display-name 109 quoted add-line-number
! 
dial-peer voice 1001 pots
 destination-pattern 110 
 port 0/1 
 user-password  EYEuHs6PTg5yZ3oUaQP5+g== encrypt
 display-name 110 quoted add-line-number
! 
dial-peer voice 1002 pots
 destination-pattern 111 
 port 0/2 
 user-password  EYEuHs6PTg5yZ3oUaQP5+g== encrypt
 display-name 111 quoted add-line-number
! 
dial-peer voice 1003 pots
 destination-pattern 112 
 port 0/3 
 user-password  EYEuHs6PTg5yZ3oUaQP5+g== encrypt
 display-name 112 quoted add-line-number
! 
! 
! 
! Voip peer configuration. 
! 
dial-peer voice 10000 voip 
 destination-pattern T 
 session target sip-server  
 session protocol sip 
 voice-class codec 0 
 no vad
 no dtmf-relay 
 translate-outgoing called-number 0 
 translate-outgoing calling-number 0 
! 
! 
! 
dial-peer call-hold h 
dial-peer call-transfer h 
! 
! 
! 
! Gateway configuration. 
! 
gateway 
 h323-id voip.192.168.1.241 
 no ignore-msg-from-other-gk 
! 
! 
! Codec classes configuration. 
! 
voice class codec 0 
 codec preference 1 g711alaw 
! 
! 
! 
! Translation Rule configuration. 
! 
translation-rule 0 
 rule 0      T                        8%02%99                          
! 
! 
! 
! SIP UA configuration. 
! 
sip-ua 
 no fault-tolerance 
 sip-server 192.168.1.254 5060 126 
 register e164 
! 
! 
! Tones 
!
! 
! 
!
line console
!
line vty
!
удалить закрыть спам изменить тег редактировать

спросил 2019-01-10 12:33:44 +0400

v0ip Gravatar v0ip flag of Russian Federation
211 25 5 16
http://v0ip.tk/

обновил 2019-03-28 17:45:54 +0400

Comments

Копать в сторону настроек addpac . Это же очевидно.

zzuz ( 2019-01-10 13:16:07 +0400 )редактировать

2 Ответа

0

1. Для регистрации отдельных пиров обязательно должно быть:

-в dial-peer voice pots :

    register e164
    user-name
    user-password

-в dial-peer voice voip :
session target sip-server

-в sip-ua:

    user-register
    sip-server 192.168.1.254
    register e164
    remote-party-id

Например, так:

dial-peer voice 1000 pots
 destination-pattern 109 
 port 0/0
 register e164
 user-name Addpac_FXS0
 user-password  EYEuHs6PTg5yZ3oUaQP5+g== encrypt
 display-name 109 quoted add-line-number

dial-peer voice 1001 pots
 ...
 register e164
 user-name Addpac_FXS1
 user-password  EYEuHs6PTg5yZ3oUaQP5+g== encrypt
 ...

2. Чтобы работали входящие с Adpack на Asterisk обязательно должно быть

 -в sip-ua :
remote-party-id

В астериске в конфиге пиров убрать или закомментировать insecure=port,invite и прописать trustrpid=yes

[109]
...
#insecure=port,invite
trustrpid=yes
...

Инвайт с авторизацией работает только в том случае, если в настройке Addpac выбрать REMOTE-PARTY-ID

-в поле From подставляется имя пира, зареганного на астере, и тогда инвайт проходит авторизацию, а CALLER-ID передается в поле Remote-Party-ID :

INVITE sip:123456789@192.168.1.254 SIP/2.0
From: <sip:Addpac_FXS0@192.168.1.254>
Remote-Party-ID: <sip:109@192.168.1.254>
ссылка удалить спам редактировать

ответил 2019-04-01 13:40:44 +0400

Olpag Gravatar Olpag
1904 3 5 29

обновил 2019-04-01 13:43:18 +0400

0

addpac может регистрировать как устройсво с одним логином и паролем. а может регистрироваться для каждого номера отдельно. https://awsswa.livejournal.com/14282.html

ссылка удалить спам редактировать

ответил 2019-01-13 17:38:31 +0400

awsswa Gravatar awsswa flag of Russian Federation
675 5 2 9

Comments

Проблема в том, что регистрируется он вроде как корректно, а именно: На нем 4 аккаунта: 109, 110, 111, 112 Когда я делаю вызов на любой из этих номеров, то попадаю к абоненту корректно, но вот все указанные абоненты звонят с Clid 109.

v0ip ( 2019-02-25 15:05:31 +0400 )редактировать

не правильно настроена регистрация - не по отдельности. в секции общей не должно быть логинов и паролец

awsswa ( 2019-03-22 17:55:19 +0400 )редактировать

Прошу прощения,а что-за "общая" секция?

v0ip ( 2019-03-26 18:33:28 +0400 )редактировать

-в sip-ua:

awsswa ( 2019-04-24 22:56:46 +0400 )редактировать

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2019-01-10 12:33:44 +0400

Просмотрен: 199 раз

Обновлен: Apr 01

Похожие вопросы:

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.