Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

Плохое распознавание сигналов DTMF

0

Здравствуйте

В офисе для входящих звонков стоят FXO шлюзы (Audiocodes MP-118 и MP-114). В Asterisk настроен IVR При звонках от одного оператора - плохо распознаются сигналы DTMF, поэтому абоненты звонят не на те момера, которые им нужны. С любого мобильного и с некоторых городских номеров - все в порядке. Такое впечатление, что частоты некоторых цифр - не те, что понимает шлюз. В основном не понимается 1 2 (как будто их вовсе не набирают.

Audiocodes настраивал на ловлю Busy все Ок.

удалить закрыть спам изменить тег редактировать

спросил 2014-09-05 12:23:44 +0400

Vechinus Gravatar Vechinus
1 1

Comments

У меня PIAF (там все из WEB делается, есть только custom-ные конфиги). Куда вствлять relaxdtmf?

Vechinus ( 2014-09-23 17:24:41 +0400 )редактировать

3 Ответа

0

можете перекомпилировать астриск выставив в опциях relaxdtmf

но с большей долей вероятности проблему не решить.

лучше выключить dtmf детект на audiocodes, выставить кодек в g711 и ловить dt,f inband астериском. у астериска более продвинутые алгоритмы распознования.

ссылка удалить спам редактировать

ответил 2014-09-05 13:13:47 +0400

meral Gravatar meral flag of Ukraine
21228 23 18 169
http://pro-sip.net/

Comments

зачем перекомпилировать? просто в sip.conf relaxdtmf=yes :) Ну и конечно dtmfmode=inband для пира

Zavr2008 ( 2014-09-14 17:43:34 +0400 )редактировать

.88- 1.8 прийдется таки перекомпилировать. по умолчанию функциональность отсутвует.

meral ( 2014-09-14 21:33:51 +0400 )редактировать

meral, может я старею? не вижу я в упор у ТС ".88-1.8" :)

Zavr2008 ( 2014-09-17 18:29:23 +0400 )редактировать

ну у него версия вообще не прописана. что не так?

meral ( 2014-09-18 23:10:21 +0400 )редактировать

meral, как раз не прописано что у него нет relaxdtmf. Пусть попробует включит и если нет, то уже занимается перекомпиляцией. Так напугали парня)

Zavr2008 ( 2014-09-20 17:35:04 +0400 )редактировать
0

Может проявляться если провайдер не пропускает DTMF в канале, а распознает его и регенерирует. В данном случае вероятно провайдер вырезал из аудио потока DTMF и слал его в регенерированном виде, как пишет автор INFO(хотя я думал, что INFO передается внутри sip). Проверить достаточно просто, во время разговора попросить звонящего зажать и подержать кнопку если провайдер ничего не делает с DTMF услышите долгий пиииииииииии, если же мое предположение верно то будет коротенький пи или вообще тишина.

ссылка удалить спам редактировать

ответил 2014-09-16 18:11:04 +0400

itprofit Gravatar itprofit
768 24 3 26
http://itprofit32.ru/
0

Спасибо за помощь, но я не нашел в web Audiocodes-а настройки для отключения детекта DTMF. Частично проблему решил, добавив в Protocol Configuration -> Protocol Definition -> DTMF & Dialing -> 2nd TX DTMF Option -> INFO(Nortel) Стало лучше работать (с оператора, где были постоянные ошибки, ошибок нет), но из дома, по аналоговой АТС - ошибки есть. Но, самое главное, шлюз стал понимать 1 2 3 цифры (бывает, что понимает неправильно, но, хотя-бы, не игнорирует, как раньше).

ссылка удалить спам редактировать

ответил 2014-09-16 10:26:13 +0400

Vechinus Gravatar Vechinus
1 1

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку
1 закладка

подписаться на rss ленту новостей

Статистика

Задан: 2014-09-05 12:23:44 +0400

Просмотрен: 268 раз

Обновлен: Sep 16 '14

Похожие вопросы:

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.