Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

Ошибка при входящем звоке

0

Добрый день, настроил двух провайдеров на Asterisk, один работает нормально, а вот со вторым есть небольшая проблема, при входящем звонке вылазит ошибка, при этом звонок проходит нормально и я могу поговорить, в консоли лезет вот это:

[Aug 27 19:06:32] ERROR[1367]: netsock2.c:269 ast_sockaddr_resolve: getaddrinfo("72.20.20.1", "5060 ", ...): Servname not supported for ai_socktype 
[Aug 27 19:06:32] WARNING[1367]: chan_sip.c:18177 check_via: Could not resolve socket address for '72.20.20.1:5060 '

Где что поправить ?

Вот настройки провайдера:

[provider]
type=peer
host=72.20.20.1
insecure=invite,port
context=provider-in
qualify=yes
dtmfmode=inband
nat=force_rport,comedia
transport=udp
disallow=all
allow=gsm
allow=alaw
allow=ulaw
удалить закрыть спам изменить тег редактировать

спросил 2014-08-27 20:13:07 +0400

Чистый Gravatar Чистый
11 4 4

обновил 2014-08-28 19:04:25 +0400

Comments

Порт с пробелом, не?

tesak89 ( 2014-08-27 21:05:31 +0400 )редактировать

нет , у него host=72.20.20.1:5060

zzuz ( 2014-08-27 23:03:20 +0400 )редактировать

'72.20.20.1:5060 ' в конце перед кавычкой.

tesak89 ( 2014-08-28 16:23:07 +0400 )редактировать

если Вы так явно не видите причины, то сделайте ping 72.20.20.1:5060 , чтобы просветлиться.

zzuz ( 2014-08-28 18:01:57 +0400 )редактировать

getaddrinfo("72.20.20.1", "5060 ", ...) "host=72.20.20.1 port=5060 "

Скорее так.

tesak89 ( 2014-08-28 18:23:22 +0400 )редактировать

Извините, а ping тут причем ? тем более что он не понимает такой формат записи хоста.

Чистый ( 2014-08-28 18:53:42 +0400 )редактировать

А это и не Вам адресовалось) По теме -- кусок конфига скиньте посмотреть

tesak89 ( 2014-08-28 18:56:43 +0400 )редактировать

Вот настройки провайдера: [provider] type=peer host=72.20.20.1 insecure=invite,port context=provider-in qualify=yes dtmfmode=inband nat=force_rport,comedia transport=udp disallow=all allow=gsm allow=alaw allow=ulaw

Чистый ( 2014-08-28 19:03:43 +0400 )редактировать

Zavr2008 вероятнее всего Вы правы, пакет от провайдера содержит пробел: Via: SIP/2.0/UDP 72.20.20.1:5060 ;branch=z9hG4bK0015172A0BAC4549AB8A57754112

Чистый ( 2014-08-29 15:33:09 +0400 )редактировать

1 Ответ

0

Походу /etc/services.

Там есть упоминание про udp/5060 ?

Можно взять готовый

ссылка удалить спам редактировать

ответил 2014-08-28 13:12:37 +0400

Zavr2008 Gravatar Zavr2008 flag of Russian Federation
2685 11 9 37
http://mh.otx.ru/

Comments

Не путайте мясо со стулом.

zzuz ( 2014-08-28 15:40:10 +0400 )редактировать

учите матчасть)))

Zavr2008 ( 2014-08-28 19:43:28 +0400 )редактировать

"Because there is a delimiter missing, after the port number, it is treating the combination of the port number and the following parameter as a name, and trying to look that up."

там пробел после 5060, в результате система считает это - именем сервиса. Не находит в /etc/services и посылает. В строке регистрации на провайдера просто нужно указать в конце тот экстен, на который регистрируемся но БЕЗ ПРОБЕЛА после порта 5060.

Zavr2008 ( 2014-08-28 19:48:27 +0400 )редактировать

insecure=invite,port - а вот это говорит, что транк без регистрации. В этом случае это к провайдеру насчет пробела..

Zavr2008 ( 2014-08-28 19:49:28 +0400 )редактировать

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2014-08-27 20:13:07 +0400

Просмотрен: 96 раз

Обновлен: Aug 28 '14

Похожие вопросы:

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.