Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

AddPac GS1002 звонит вникуда

0

Связка AddPac и Elastix

Все порты нормально зарегистрированы на elastix'e

Делаю первый звонок на GSM. Шлюз нормально пробрасывает звонок на Elastix. Если elastix по каким то причинам отбивает звонок, то шлюз болше с этого порта не звонит в elastix...

Делаю второй звонок на этот же порт GSM и вижу в логах что шлюз отправляет вызов в непонятном мне направлении.

Вот debug шлюза:

Первый звонок - удачный:

GS1002(config)# 664 <CEP    000100> : Call Received 
    665 <CEP    000100> : Call Received 
    666 <CEP    000100> : Call Initiated : calledNumber() crv(0) total(0)
    667 <Call   8>  : ******  Call Created status(InitiatedByMobile) ver(8.51:2011-02-06-00-00) time(1371571453) ****  
    668 <CEP    000100> : Decode CID : FFFFFF80  E 10  C 2B 37 39 31 38 35 35 35 34 34 32 35 
    669 <CEP    000100> : Mobile CID : time() callingNumber(7918ххххххх) callingName()
    670 <CEP    000100> : Calling number(7918ххххххх)
    671 <CEP    000100> : Call id(fd84c051-5dce-de4a-8014-0002a409113c) callNum(8)
    672 <Call   8>  : MatchAllProcess After Sorted
                  <0>  id(0) dest(T) prefer(0) selected(0)
                  <1>  id(2) dest(T) prefer(0) selected(0)
                  <2>  id(4) dest(T) prefer(0) selected(0)
                  <3>  id(3) dest(T) prefer(0) selected(0)
                  <4>  id(1) dest(T) prefer(0) selected(0)
    673 <Call   8>  : Initiate callee with dial-peer(T) status(CalleeDeterminedAll) id(fd84c051-5dce-de4a-8014-0002a409113c) 
    674 <NetEP  8>  : InitiateOutCall: calledNum(600) callingNum(7918ххххххх) target(sip-server)
    675 <NetEP  8>  : DoCall: calledAddr(sip:600@192.168.0.11:5060) callingAddr(7918ххххххх)
    676 <SIP    8>  : SetLocalAudioFormats : outbound(TRUE) hqaEnable(FALSE) 
    677 <SIP    8>  : SetLocalAudioFormats : myVoipPeer(0) is not NULL, codec(4)
    678 <SIP    8>  : SetLocalAudioFormats : outbound(TRUE) hqaEnable(FALSE) 
    679 <SIP    8>  : SetLocalAudioFormats : myVoipPeer(0) is not NULL, codec(4)
    680 <SIP    0>  : No authentication information available 
    681 <SIP    8>  : Send INVITE Request 
    682 <SIP    8>  : Receive 401 Unauthorized
    683 <SIP    8>  : Transaction (3 INVITE) completed
    684 <SIP    8>  : Send ACK Request 
    685 <SIP    0>  : No opaque in authentication 
    686 <SIP    0>  : Adding authentication information
    687 <SIP    8>  : Send INVITE Request 
    688 <SIP    8>  : Receive 403 Forbidden
    689 <SIP    8>  : Transaction (4 INVITE) completed
    690 <SIP    0>  : Adding authentication information
    691 <SIP    8>  : Send ACK Request 
    692 <SIP    8>  : Check Event Relation code(403)
    693 <SIP    8>  : ReleaseWithNothing 
    694 <Call   8>  : Terminated from(fffffffe) this(Remote:NoPermission) before(<NULL>) forced(0) time(1371571453)
    695 <CEP    000100> : DisconnectCall at Busy
    696 <CEP    000100> : StopSignal
    697 <CEP    000100> : Disconnect (0) 
    698 <NetEP  8>  : Call TO <sip:600@192.168.0.11> terminated reason(Remote:NoPermission)
    699 <CEP    000100> : Disconnected(16) at Disconnecting 
    700 <CEP    000100> : Disconnected(16) at Idle 

    GS1002(config)# 
    GS1002(config)# 
    GS1002(config)# 
    GS1002(config)# 
    GS1002(config)# 
    GS1002(config)# 
    GS1002(config)# 
    GS1002(config)#

Меня отбил elastix по причине, что не нашел нужного экстеншена. Я делаю маленькую паузу и звоню повторно:

GS1002(config)# 
GS1002(config)# 
GS1002(config)# 
GS1002(config)# 
GS1002(config)# 
GS1002(config)# 701 <CEP    000100> : Call Received 
702 <CEP    000100> : Call Received 
703 <CEP    000100> : Call Initiated : calledNumber() crv(0) total(0)
704 <Call   9>  : ******  Call Created status(InitiatedByMobile) ver(8.51:2011-02-06-00-00) time(1371571470) ****  
705 <CEP    000100> : Decode CID : FFFFFF80  E 10  C 2B 37 39 31 38 35 35 35 34 34 32 35 
706 <CEP    000100> : Mobile CID : time() callingNumber(7918ххххххх) callingName()
707 <CEP    000100> : Calling number(7918ххххххх)
708 <CEP    000100> : Call id(0e85c051-6449-600a-8017-0002a409113c) callNum(9)
709 <Call   9>  : MatchAllProcess After Sorted
              <0>  id(4) dest(T) prefer(0) selected(0)
              <1>  id(3) dest(T) prefer(0) selected(0)
              <2>  id(0) dest(T) prefer(0) selected(1)
              <3>  id(2) dest(T) prefer(0) selected(0)
              <4>  id(1) dest(T) prefer(0) selected(0)
710 <Call   9>  : Initiate callee with dial-peer(T) status(CalleeDeterminedAll) id(0e85c051-6449-600a-8017-0002a409113c) 
711 <CEP    000300> : InitiateOutCall :  calledNum(600), callingNum(7918ххххххх), callerPort(100) type(FXO) 
712 <CEP    000300> : Outbound call to CEP callId(0e85c051-6449-600a-8017-0002a409113c) callNum(9)
713 <Call   9>  : Connected from(100) 
714 <Call   9>  : Connected from(300) 
715 <CEP    000100> : Disconnected(16) at Busy 
716 <Call   9>  : Terminated from(100) this(Local:CallClear) before(<NULL>) forced(0) time(1371571474)
717 <CEP    000100> : DisconnectCall at Idle
718 <CEP    000300> : DisconnectCall at Busy
719 <CEP    000300> : StopSignal
720 <CEP    000300> : Disconnect (0) 
721 <CEP    000300> : Disconnected(16) at Disconnecting 

GS1002(config)#

При повторном вызове шлюз почему то определяет, что звонок пришел с FXO порта callerPort(100) type(FXO)

Вот мой конфиг

GS1002# show run
Building configuration...

Current configuration:
!
version 8.51.008
!
hostname GS1002
clock timezone moscow 4
!
username root password router administrator
username guest password guest user
!
!
script ntpdate default
 server ip 0.pool.ntp.org
 server ip 1.pool.ntp.org
!
interface Loopback0
 ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
 ip address 192.168.0.12 255.255.255.0
 ip nat outside
 speed auto
 no qos-control
!
interface FastEthernet0/1
 no ip address
 ip nat outside
 speed auto
 no qos-control
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1 10
!
access-list 100 permit ip any any
!
!
ip nat inside source list 100 interface FastEthernet0/0  overload
!
!
!
ftp server
http server
!
dns name-server 192.168.0.1
logging command
logging event 4-warning
logging on
! 
! 
! 
! 
! VoIP configuration. 
! 
! 
! Voice service voip configuration. 
! 
voice service voip 
 protocol sip
 dtmf-relay out-of-band
 fax protocol t38 redundancy 0 
 fax rate 9600 
 h323 call start fast 
 h323 call tunnel enable 
 no call-barring unconfigured-ip-address
 no voip-inbound-call-barring enable
! 
! 
! Voice port configuration. 
! 
! GSM 
voice-port 0/0 
 connection plar 600 
 dial-tone-generate 
 caller-id enable 
! 
! 
! GSM 
voice-port 0/1 
 connection plar 600 
 dial-tone-generate 
 caller-id enable 
 caller-id type etsi 
! 
! 
! FXO 
voice-port 0/2 
 connection plar 600 
 caller-id enable 
! 
! 
! FXO 
voice-port 0/3 
 connection plar 600 
 caller-id enable 
! 
! 
! 
! 
! service port group configuration. 
! 
! 
! 
! Pots peer configuration. 
! 
dial-peer voice 1 pots
 destination-pattern T 
 port 0/0 
 call-waiting
 user-name GSM1 
 user-password passGSM1 
! 
dial-peer voice 2 pots
 destination-pattern T 
 port 0/1 
 user-name GSM2 
 user-password passGSM2 
! 
dial-peer voice 3 pots
 destination-pattern T 
 port 0/2 
 user-name FXO1 
 user-password passFXO1 
! 
dial-peer voice 4 pots
 destination-pattern T 
 port 0/3 
 user-name FXO2 
 user-password passFXO2 
! 
! 
! 
! Voip peer configuration. 
! 
dial-peer voice 0 voip 
 destination-pattern T 
 session target sip-server  
 session protocol sip 
 codec g729 
 voice-class codec 729 
 no vad
 dtmf-relay rtp-2833 
 description asterisk 
! 
! 
! 
! 
! 
! 
gatekeeper
! 
! 
! Gateway configuration. 
! 
gateway   
 h323-id voip.192.168.0.11 
 no ignore-msg-from-other-gk 
 shutdown 
! 
! 
! Codec classes configuration. 
! 
voice class codec 0 
 codec preference 1 g729 
! 
! 
! 
! SIP UA configuration. 
! 
sip-ua 
 user-register 
 sip-server 192.168.0.11 5060 126 
 timeout treg 120 
 timeout tregtry 1800 
 register e164 
! 
! 
! Tones 
!
! 
! 
! 
! SMTP sendmail configuration 
! 
sms-delivery 
! 
! 
!
line console
!
line vty
!
mobile dev-restart-by-unreg 300
!
mobile 0/0
 gsm sms-language utf8
!
mobile 0/1
 gsm sms-language utf8
!
end
GS1002#

Помогите понять что происходит и как это исправить???

удалить закрыть спам изменить тег редактировать

спросил 2013-06-18 20:48:57 +0400

wellus Gravatar wellus
49 19 9

Comments

Прямо эпидемия какая-то у купивших эти поделки

switch ( 2013-06-18 21:55:38 +0400 )редактировать

1 Ответ

1

У вас все одинаковые destination-pattern T, т.е. звонок может идти может на любой порт включая voip. определите префиксы звонков. Например

dial-peer voice 1 pots
destination-pattern 79T
port 0/0
call-waiting
user-name GSM1
user-password passGSM1
!
dial-peer
voice 2 pots
destination-pattern 79T
port 0/1
user-name GSM2
user-password passGSM2

dial-peer voice 0 voip
destination-pattern 600
session target sip-server
session protocol sip
codec g729
voice-class codec 729
no vad
dtmf-relay rtp-2833
description asterisk

Так же можно использовать преобразование номера для выбора линии

ссылка удалить спам редактировать

ответил 2013-06-18 21:21:40 +0400

Master135 Gravatar Master135
431 1 3 10

обновил 2013-06-18 21:28:03 +0400

Comments

Я не подумал, что шлюз может делать "заворот" с порта на порт...

Спасибо, подправил destination-pattern и шлюзу явно полегчало )))

wellus ( 2013-06-19 00:22:14 +0400 )редактировать

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2013-06-18 20:48:57 +0400

Просмотрен: 607 раз

Обновлен: Jun 18 '13

Похожие вопросы:

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.