Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

AddPac GS1002 нет запросов на регистрацию

0

Пытаюсь связать AddPac GS 1002 и Asterisk.

Проблема в том, что AddPac не посылает запросов на регистрацию на Asterisk. На стороне Asterisk'a слушаю и Sip debug'ом и tcpdump'ом - тишина.

В iptables все чисто...

Вот только пинги с AddPac'а на Asterisk проходят какие-то странные с задержкой 0 мс:

PING 192.168.0.11 (192.168.0.12): 56 data bytes
64 bytes from 192.168.0.11: icmp_seq=0 ttl=64 time=0 ms
64 bytes from 192.168.0.11: icmp_seq=1 ttl=64 time=0 ms
64 bytes from 192.168.0.11: icmp_seq=2 ttl=64 time=0 ms
64 bytes from 192.168.0.11: icmp_seq=3 ttl=64 time=0 ms
64 bytes from 192.168.0.11: icmp_seq=4 ttl=64 time=0 ms

--- 192.168.0.11 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss'
round-trip min/avg/max = 0/0/0 ms

Вот конфиг AddPac:

GS1002# show run
Building configuration...

Current configuration:
!
version 8.51.008
!
hostname GS1002
!
username root password router administrator
username guest password guest user
!
!
interface Loopback0
 ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
 no ip address
 ip nat outside
 speed auto
 no qos-control
!
interface FastEthernet0/1
 ip address 192.168.0.12 255.255.255.0
 ip nat inside
 speed auto
 no qos-control
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1 10
!
!
!
!
http server
!
dns name-server 192.168.0.1
logging command
logging event 4-warning
logging on
! 
! 
! 
! 
! VoIP configuration. 
! 
! 
! Voice service voip configuration. 
! 
voice service voip 
 protocol sip
 dtmf-relay out-of-band
 fax protocol t38 redundancy 0 
 fax rate 9600 
 h323 call start fast 
 h323 call tunnel enable 
 no call-barring unconfigured-ip-address
 no voip-inbound-call-barring enable
! 
! 
! Voice port configuration. 
! 
! GSM 
voice-port 0/0 
 connection plar 600 
 dial-tone-generate 
 caller-id enable 
 caller-id type etsi 
 caller-id name disable
! 
! 
! GSM 
voice-port 0/1 
 connection plar 600 
 dial-tone-generate 
 caller-id enable 
 caller-id type etsi 
 caller-id name disable
! 
! 
! FXO 
voice-port 0/2 
 connection plar 600 
 caller-id enable 
! 
! 
! FXO 
voice-port 0/3 
 connection plar 600 
 caller-id enable 
! 
! 
! 
! 
! service port group configuration. 
! 
! 
! 
! Pots peer configuration. 
! 
dial-peer voice 1 pots
 destination-pattern .T 
 port 0/0 
 call-waiting
 user-name GSM1 
 user-password GSM1
! 
dial-peer voice 2 pots
 destination-pattern T 
 port 0/1 
 user-name GSM2 
 user-password GSM2 
! 
dial-peer voice 3 pots
 destination-pattern .T 
 port 0/2 
 user-name FXO1 
 user-password FXO1 
! 
! 
! 
! Voip peer configuration. 
! 
dial-peer voice 0 voip 
 destination-pattern .T 
 session target ip 192.168.0.11  
 session protocol sip 
 voice-class codec 0 
 no vad
 dtmf-relay rtp-2833 
 description asterisk 
! 
! 
! 
! 
dial-peer call-hold h 
dial-peer call-transfer h 
! 
dial-peer hunt 2 
! 
! 
gatekeeper
! 
! 
! Gateway configuration. 
! 
gateway 
 h323-id voip.192.168.0.12 
 no ignore-msg-from-other-gk 
! 
! 
! Codec classes configuration. 
! 
voice class codec 0 
 codec preference 1 g711alaw 
! 
! 
! 
! Translation Rule configuration. 
! 
! 
! 
! 
! SIP UA configuration. 
! 
sip-ua 
 user-register 
 sip-username AddPac 
 sip-password AddPac 
 sip-server 192.168.0.11 
 called-party-number to-field
 register e164 
! 
! 
! Tones 
!
! 
! 
! 
! SMTP sendmail configuration 
! 
sms-delivery 
! 
! 
!
line console
!
line vty
!
mobile dev-restart-by-unreg 300
!
mobile 0/0
 gsm sms-language utf8
!
mobile 0/1
 gsm sms-language utf8
!         
end
GS1002#

Причем вначале запросы были, но пока разбирался чо к чему, пропали, и я не могу их заставить снова появиться...

Может будут мысли где копнуть?

удалить закрыть спам изменить тег редактировать

спросил 2013-06-17 18:05:47 +0400

wellus Gravatar wellus
49 19 9

3 Ответа

1

Чтобы работала регистрация через FastEthernet 0/1, добавьте

voip-interface ip FastEthernet 0/1

Либо перенастройте на FastEthernet 0/0, как вам посоветовали.

ссылка удалить спам редактировать

ответил 2013-06-18 12:37:46 +0400

Master135 Gravatar Master135
431 1 3 10
0
interface FastEthernet0/0


no ip address

и где адрес ? или где настройка получения адреса по dhcp ? и факс лучше ходит в режиме duplex-t38 redundancy 3, где настройки получения времени через ntp, где точечные настройки FXO портов - они сами трубку не положат

ссылка удалить спам редактировать

ответил 2013-06-17 19:17:55 +0400

awsswa Gravatar awsswa flag of Russian Federation
456 5 2 7

обновил 2013-06-17 19:23:00 +0400

Comments

Адрес вот:

interface FastEthernet0/1

ip address 192.168.0.12 255.255.255.0

ip nat inside

speed auto

no qos-control

wellus ( 2013-06-17 19:25:43 +0400 )редактировать

"...факс лучше ходит в режиме duplex-t38 redundancy 3..."

Учту в дальнейшем

"...точечные настройки FXO портов - они сами трубку не положат..."

это hangup им прописать? хорошо, тоже учту в дальнейшем...

Пока что, меня волнует то, что шлюз не посылает запросов на регистрацию - как это решить?

wellus ( 2013-06-17 19:31:07 +0400 )редактировать
1

есть wan интерфейс и есть lan интерфейс - регистрации идет всегда только с wan

awsswa ( 2013-06-17 20:06:56 +0400 )редактировать

Сам себя?... Вот:

PING 192.168.0.12 (192.168..102): 56 data bytes

64 bytes from 192.168.0.12: icmp_seq=0 ttl=64 time=0 ms

64 bytes from 192.168.0.12: icmp_seq=1 ttl=64 time=0 ms

64 bytes from 192.168.0.12: icmp_seq=2 ttl=64 time=0 ms

64 bytes from 192.168.0.12: icmp_seq=3 ttl=64 time=0 ms

64 bytes from 192.168.0.12: icmp_seq=4 ttl=64 time=0 ms

--- 192.168.0.12 ping statistics ---

5 packets transmitted, 5 packets received, 0% packet loss'

round-trip min/avg/max = 0/0/0 ms

wellus ( 2013-06-17 20:24:16 +0400 )редактировать

где адрес wan ? interface FastEthernet0/0

awsswa ( 2013-06-17 20:25:55 +0400 )редактировать

"...

есть wan интерфейс и есть lan интерфейс - регистрации идет всегда только с wan awsswa (6 mins ago)

..."

не знал! завтра попробую перенастроить порты - отпишусь...

Но у меня была регистрация с порта LAN сегодня утром и я порты не перетыкал...

wellus ( 2013-06-17 20:26:40 +0400 )редактировать

"...

где адрес wan ? interface FastEthernet0/0

awsswa (10 mins ago)

..."

Ну вот я почему то решил что мне выпускать ее во внешнюю сеть не нужно, я и настроил на LAN порту

wellus ( 2013-06-17 20:27:55 +0400 )редактировать

я что, заставляю её голой жопой в интернет выставить ? кабель из LAN в WAN переставьте, я надеюсь вы addpac за место роутера не используете ?

awsswa ( 2013-06-17 22:07:45 +0400 )редактировать

awsswa - я не спорю, я не знал о таком нюансе, что регистрация идет только через WAN.

Перенастроил на WAN порт и все заработало. Спасибо.

wellus ( 2013-06-18 18:33:05 +0400 )редактировать

прошивку к стате можете обновить на http://www.addpac.com/webhard/Harry/Russia/EMAG/GSM/gs1002g2v851010.bin

awsswa ( 2013-06-18 21:36:19 +0400 )редактировать
0

Для регистрации отдельных пиров, в конфиге должны присутствовать следующие строки :

в dial-peer voice pots :

register e164
user-name
user-password

в dial-peer voice voip :

session target sip-server

в sip-ua :

user-register
sip-server
register e164
ссылка удалить спам редактировать

ответил 2013-06-18 13:04:38 +0400

Olpag Gravatar Olpag
1884 3 4 29

обновил 2013-06-18 13:06:45 +0400

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2013-06-17 18:05:47 +0400

Просмотрен: 883 раз

Обновлен: Jun 18 '13

Похожие вопросы:

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.