Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

Addpac gs1001 + Asterisk дублирование DTMF

0

День добрый.

Ситуация следующая - при звонке на AddPac звонок редиректится на Asterisk на номер 777, далее после нажатия кнопки "9" и ввода пароля, можно позвонить вовне через АТС.

Так вот проблема возникает либо при наборе пароля, либо при наборе внешнего номера: задваивается часть вводимых цифр и, соответственно, звонок никуда не идёт из-за некорректного номера.

Конфиг Addpac:

!
! APOS(tm) configuration saved from vty
!  2013/03/27 12:33:53 
!
version 8.51.002
!
hostname GS1001
clock timezone MSK 4
!
username root password router administrator
username guest password guest user
!
!
script ntpdate default
 resynchronize 12 0
 server ip 192.168.0.1
!
interface Loopback0
 ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
 ip address 192.168.0.222 255.255.255.0
 ip nat outside
 speed auto
 no qos-control
!
interface FastEthernet0/1
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 speed auto
 no qos-control
!
ip route 0.0.0.0 0.0.0.0 192.168.0.254 10
!
!
!
!
http server
!
dns name-server 8.8.8.8
dns name-server 8.8.4.4
logging command
logging event 4-warning
logging on
! 
! 
! 
! 
! VoIP configuration. 
! 
! 
! Voice service voip configuration. 
! 
voice service voip 
 protocol sip
 dtmf-relay rfc-2833
 fax protocol t38 redundancy 0 
 fax rate 9600 
 h323 call start fast 
 h323 call tunnel enable 
 no call-barring unconfigured-ip-address
 no voip-inbound-call-barring enable
! 
! 
! Voice port configuration. 
! 
! GSM 
voice-port 0/0 
 connection plar 777 
 caller-id enable 
! 
! 
! 
! 
! service port group configuration. 
! 
! 
! 
! Pots peer configuration. 
! 
dial-peer voice 1 pots
 destination-pattern 9 
 port 0/0 
 user-password sip123 
! 
! 
! 
! Voip peer configuration. 
! 
dial-peer voice 0 voip 
 destination-pattern 777 
 session target sip-server  
 session protocol sip 
 no vad
 dtmf-relay rtp-2833 
! 
! 
! 
! 
! 
! 
gatekeeper
! 
! 
! Gateway configuration. 
! 
gateway 
 h323-id voip.192.168.0.222 
 no ignore-msg-from-other-gk 
! 
! 
! Codec classes configuration. 
! 
voice class codec 0 
! 
! 
! 
! SIP UA configuration. 
! 
sip-ua 
 sip-server SIP_SERVER 5060 126 
 register e164 
! 
! 
! Tones 
!
! 
! 
!
line console
!
line vty
!
gsm dev-restart-by-unreg 300
!
gsm 0/0
 sms-language utf8
!

Dial-план такой:

exten => 777,1,Goto(extcalls,s,1)

[extcalls]                                                                                                                                                                                    
exten => 777,1,Set(NUM=${DB(whitelist/${CALLERID(num)})})                                                                                                                                     
exten => 777,2,GotoIf($[${ISNULL(${NUM})}]?blocked,1)                                                                                                                                         
exten => 777,n,Answer()                                                                                                                                                                       
exten => 777,n,Background(777)                                                                                                                                                                
exten => 777,n,Waitexten(10)                                                                                                                                                                  
exten => 9,1,Authenticate(1234)                                                                                                                                                               
exten => 9,n,DISA(no-password,to_outside)                                                                                                                                                     
exten => 777,n,Hangup()                                                                                                                                                                       

exten => blocked,1,Playback(vm-goodbye)                                                                                                                                                       
   same => n,Hangup()                                                                                                                                                                         


[to_outside]                                                                                                                                                                                  
exten => _8X.,1,Dial(SIP/SIP_TRUNK/${EXTEN})

Для номера 777 dtmfmode установлен rfc2833.

Пробовал играться с параметрами:

timing dtmf-duration 
timing dtmf-guard

но безрезультатно, цифры дублируются всё равно.

Может кто знает и подскажет как решить проблему с дублированием?

удалить закрыть спам изменить тег редактировать

спросил 2013-03-27 14:34:06 +0400

G@riK Gravatar G@riK
1 1

Comments

А в каком именно разделе настроек AddPac нужно подбирать: dial-peer voice 0 voip или voice service voip или и там и там?

G@riK ( 2013-03-27 14:56:17 +0400 )редактировать

Пробовал на Addpac "играться" с dtmfmode (совместно с астрериском). Гарантированно правильные символы на АТС передаются только при rfc-2833, но задвоения есть.

Пробовал убирать/включать echo-cancellation, изменять параметры input/output gain - положительных результатов нет.

G@riK ( 2013-03-28 14:23:39 +0400 )редактировать

2 Ответа

1

Подберите правильно режим передачи DTMF на устройстве и астериске (dtmfmode).

ссылка удалить спам редактировать

ответил 2013-03-27 14:47:00 +0400

switch Gravatar switch
8334 11 7 91
http://lynks.ru/
0

Возможно это из-за эха. Поиграйтесь с громкостью линии.

ссылка удалить спам редактировать

ответил 2013-03-27 18:37:31 +0400

Master135 Gravatar Master135
431 1 3 10

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку
1 закладка

подписаться на rss ленту новостей

Статистика

Задан: 2013-03-27 14:34:06 +0400

Просмотрен: 425 раз

Обновлен: Mar 27 '13

Похожие вопросы:

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.