Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

дистрибутив для *

0

кто какой дистрибутив использует для * ? очень заманчиво использовать CentOS 5 с репозиториями от digium, но при необходимости использовать chan_dongle ядро нужно >=2.6.33 я так понимаю остается вариант сборка из исходников например на debian wheezy или gentoo что посоветуете?

Мой опыт:

Не люблю компилить из исходников в бинарных дистрибутивах, поэтому всегда использовал centos 5 и репозитории asterisk и digium, но тут пришел dongle и пришлось делать то что не очень люблю. С ядром тоже не все гладко (e153 и e173 не хотят работать с ядром 2.6.18, односторонняя слышимость) прикрутил к centos 5 ядро 2.6.35 и за исключением нескольких мелочей все работает, но встает вопрос стоит ли так заморачиваться со всеми этими костылями и сentos. Попробовал собрать все на gentoo (ebuild для dongle в сети есть) все завелось и заработало, в продакшен пока еще не запустил, но все к тому идет.

удалить закрыть спам изменить тег редактировать

спросил 2013-01-23 18:44:45 +0400

yannails Gravatar yannails
81 9 4

обновил 2013-02-02 13:37:28 +0400

Comments

при использовании chan_dongle вам все равно его прийдется из исходников собирать,не? дистрибутив ТОЛЬКО centos, причем еще и процессор интел. ибо на остальном оно не тестируется нормально.

meral ( 2013-01-24 08:58:19 +0400 )редактировать

ух скольок експертов появилося. надо было формулировать вопрос "сколько у вас было неудачных инсталяций и на каких ос". зы все повторяющиеся ответы удаляем.если ваш вариант есть,плюсуйте под ним и в коменты.

meral ( 2013-01-28 23:33:42 +0400 )редактировать

2.6.18 это centos 5, в centos 6 ядро 2.6.32 не пробовали?

Out ( 2013-02-02 13:50:48 +0400 )редактировать

а смысл? репозитория asterisk для 6 еще нет, при тех же условиях можно попробовать asterisk на oracle linux повесить, там ядро 2.6.39

yannails ( 2013-02-04 00:01:53 +0400 )редактировать

9 Ответов

1

Поддерживаю всех. CentOS

ссылка удалить спам редактировать

ответил 2013-01-23 20:05:17 +0400

rayden8 Gravatar rayden8
250 34 11
0

Кто подскажет какую версию астера выбирать при установки дистро 3 чтоб модем прикрутить

ссылка удалить спам редактировать

ответил 2013-01-25 11:24:47 +0400

jr Gravatar jr
1 5 3

обновил 2013-01-25 11:25:47 +0400

Comments

Вам выше написали стабильную версию дистро, попробовать не судьба?

Out ( 2013-01-25 11:55:22 +0400 )редактировать

При установке можно выбрать 3 версии asteriska Они все будут работать с модемом ?

jr ( 2013-01-25 12:07:55 +0400 )редактировать
0

Рекомендую CentOS 5 или 6. Ещё ни разу не подводили.

ссылка удалить спам редактировать

ответил 2013-01-23 19:32:49 +0400

amonra Gravatar amonra flag of Ukraine
2261 24 13 63
http://lantec.ua/
0

Если уж о дистрибьютиве, то: http://downloads.freepbxdistro.org/ISO/FreePBX-3.211.63-3-x86_64-Full-1357258949.iso проверенный. Все настроено, в том числе все модули. И зачем себе мозг выносить напрасно без этого дистриба? ;)

и 32 битная версия: http://downloads.freepbxdistro.org/ISO/FreePBX-3.211.63-3-i386-Full-1357260716.iso

ссылка удалить спам редактировать

ответил 2013-01-24 00:06:25 +0400

Out Gravatar Out
712 5 3 19

обновил 2013-01-24 00:07:27 +0400

0

На стандартном ядре все работает и chan_dongle и модемы. Новое ядро (2.6.39 и старше)нужно пока только ради одного USB модема и то только для его драйверов. И пора наверно на ветку 6.3 перейти ?

ссылка удалить спам редактировать

ответил 2013-01-23 19:34:20 +0400

awsswa Gravatar awsswa flag of Russian Federation
456 5 2 7

Comments

я неправильно выразился, chan_dongle работает, но при звонках через модемы (E153 и E173) односторонняя слышимость, на 2.6.39 звук есть

yannails ( 2013-01-23 23:00:14 +0400 )редактировать

Значит что-то вы не так делаете, пока только E150 требуют новое ядро.

awsswa ( 2013-01-24 07:19:20 +0400 )редактировать
0

Использую Gentoo и Debian

ссылка удалить спам редактировать

ответил 2013-01-24 16:26:41 +0400

CheeZ Gravatar CheeZ
1055 6 6 24
0

У меня астер вообще на FreeBSD и ничего, работает, не жалуется :) Хотя я конечно получаю от прова SIP потому может и проблем не знаю.

ссылка удалить спам редактировать

ответил 2013-01-25 10:24:34 +0400

Злобный Мыш Gravatar Злобный Мыш
292 13 3 16

Comments

а может просто повезло. на фрибсд вообще 50 на 30 шанс. и еще 20 чтопроблемы появятся потом.

meral ( 2013-01-25 10:38:53 +0400 )редактировать

может и повезло. уже 2 года стоит. 1,8,17 астер, фряха 8,2

Злобный Мыш ( 2013-01-25 10:42:05 +0400 )редактировать
0

а я на убунте все сделал.. правда у меня нагрузка инкакая - максимум 72 одновременных на центральном серваке, и по 12 на мелких филиальских.

ссылка удалить спам редактировать

ответил 2013-01-27 12:32:36 +0400

Romirin Gravatar Romirin
1
0

У меня на Debian 6 Squeeze все астериски - я уже забыл где сервера стоят.

ссылка удалить спам редактировать

ответил 2013-01-28 23:28:37 +0400

mistral Gravatar mistral flag of Ukraine
370 2 5 19

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2013-01-23 18:44:45 +0400

Просмотрен: 799 раз

Обновлен: Feb 02 '13

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.