Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

Unable to load config sip.conf при создании extconfig.conf

0

Добрый день! Наткнулся на проблему при конфигурации ARA.

При создании файла extconfig.conf со следующим содержанием:

[settings]
sip.conf => odbc,asterisk-connector,sip_buddies
;sipusers => odbc,asterisk-connector,sip_buddies

получаю ошибку: chansip.c: Unable to load config sip.conf Если строки закоментировать то chansip.co загружается без проблем. В чем здесь может быть ошибка?

И еще вопрос, правильно я понимаю, что при использовании odbc драйвера в поле database надо указывать не имя базы данных, а dsn как в res_odbc.conf?

[asterisk]
enabled => yes
dsn => asterisk-connector
username => asteriskpbx
password => 123pbx
pooling => no
limit => 1
pre-connect => yes

Система Asterisk 1.8 на CentOS 5.8

Спасибо!

Поясню, строчка

sip.conf => odbc,asterisk-connector,sip_buddies

взялась от того, что я пытался заставить работать Extconfig - Static Configs как описано здесь:link text

Там указано именно sip.conf => mysql,asterisk Т.е. все-таки это не бред и почему не заработало мне не понятно.

А вот если оставить только строку

sipusers => odbc,asterisk-connector,sip_buddies

то да! sip модуль загрузился. Это я как то прошляпил мог бы и раньше проверить.

Теперь я создал базы как указано здесь link text И если добавлю в базу пользователя и.... включу телефон, то он должен авторизоваться на *.Правильно?

Что-то этого не произошло((( Я создал пользователя заполнив только поля name и secret в базе sip_buddies. Может этого недостаточно?

Мой текущий конфиг:

res_mysql.conf
[general]
dbhost = 127.0.0.1
dbname = asterisk
dbuser = asteriskpbx
dbpass = 123pbx
dbport = 3306

res_odbc.conf
[asterisk]
enabled => yes
dsn => asterisk-connector
username => asteriskpbx
password => 123pbx
pooling => no
limit => 1
pre-connect => yes

extconfig.conf
sipusers => odbc,general,sip_buddies

Это ОК?

удалить закрыть спам изменить тег редактировать

спросил 2012-09-26 16:23:36 +0400

zlobotron Gravatar zlobotron
33 15 8

обновил 2012-09-26 18:28:04 +0400

Comments

Спасибо огромное все ответившим! С утра и на свежую голову разобрался! Самым полезным советом оказался - "вам надо понимать что за вас никто дебажить бесплатно не будет." Оказывается в логах масса полезной информации )))) Сейчас пользователи добавленные в мускул авторизуются и звонятся между собой.

zlobotron ( 2012-09-27 11:10:25 +0400 )редактировать

3 Ответа

0

Да, у меня вроде так же сделано... Может полей или разрешений не хватает?

ссылка удалить спам редактировать

ответил 2012-09-26 16:48:52 +0400

switch Gravatar switch
8334 11 7 91
http://lynks.ru/

Comments

да ну? и также sip.conf ?

meral ( 2012-09-26 16:52:59 +0400 )редактировать

не, вот так:

sippeers => odbc,lpbx-realtime-select-pri,sip

sipusers => odbc,lpbx-realtime-select-pri,sip

switch ( 2012-09-26 16:56:37 +0400 )редактировать
0

ну проблема очевидно в том,что вы какойто бред написали.

правильная строчка закоментирована

что вы делаете - непонятно

таблица sip_buddies вообще не того формата который для sip.conf допускается.

ссылка удалить спам редактировать

ответил 2012-09-26 16:52:20 +0400

meral Gravatar meral flag of Ukraine
21228 24 19 169
http://pro-sip.net/

Comments

Хм, а откуда вы знаете какого у меня формата таблица? Или само имя неправильное? Таблицу взял отсюда http://www.voip-info.org/wiki/view/Asterisk+RealTime+Sip

zlobotron ( 2012-09-26 17:30:39 +0400 )редактировать

потомучт имя у вас таблиц такое. вон гляньте выше свич написал как обычно выглядит. то что вы написали это загрузка всего файла конфигурации из базы. там совсем дургой формат.

meral ( 2012-09-26 17:44:40 +0400 )редактировать

по ссылке выше написано кстатив ВВЕРХУ extconfig правильно.а у вас неправильно

meral ( 2012-09-26 17:47:26 +0400 )редактировать

Извините, я запутался. Вот мой конфиг как он выглядит сейчас: extconfig.conf [settings] sipusers => odbc,general,sip_buddies

res_mysql.conf [general] dbhost = 127.0.0.1 dbname = asterisk dbuser = asteriskpbx dbpass = 123pbx dbport = 3306

res_odbc.conf [asterisk] enabled => yes dsn => asterisk-connector username => asteriskpbx password => 123pbx pooling => no limit => 1 pre-connect => yes Это ок? Мда, здесь не читабельно. Добавил в первоначальное сообщение.

zlobotron ( 2012-09-26 18:18:36 +0400 )редактировать

ну жто отличается от того что в начале,не?

meral ( 2012-09-26 18:25:24 +0400 )редактировать

Отличается, но все равно не работает. Клиента которого добавил в базу как описал в сообщении не вижу на *.

zlobotron ( 2012-09-26 18:30:15 +0400 )редактировать

тут две проблемы может быть. 1) isql asterisk-connector не работает. 2 ) asterisk -rx "realtime odbc show". вообще вам надо понимать что за вас никто дебажить бесплатно не будет.

meral ( 2012-09-26 20:04:27 +0400 )редактировать
0

вы уверены что хотите залить именно sip.conf и именно в sip_buddies ?

еслить сильное подозрение что с sip.conf вы погорячились...

ссылка удалить спам редактировать

ответил 2012-09-26 16:55:26 +0400

komrad123 Gravatar komrad123
3780 5 3 42

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2012-09-26 16:23:36 +0400

Просмотрен: 536 раз

Обновлен: Sep 26 '12

Похожие вопросы:

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.