Пожалуйста, войдите здесь. Часто задаваемые вопросы О нас
Задайте Ваш вопрос

monast на 64bit Linux

1

Никто не сталкивался с проблемой запуска monast на 64 линуксе ? На аналогичной 32х битной платформе все работает, здесь же не находит модули питона.

удалить закрыть спам изменить тег редактировать

спросил 2012-07-11 11:22:42 +0400

telefonist Gravatar telefonist
61 16 6

2 Ответа

0

Вопрос скорей не о 64-ом Linux как таковом, а о конкретном дистрибутиве и как вы его пытаетесь ставить - у меня в Debian и Gentoo таких проблем нет.

ссылка удалить спам редактировать

ответил 2012-07-11 12:15:09 +0400

CheeZ Gravatar CheeZ
1055 6 6 24

обновил 2012-07-11 12:15:49 +0400

Comments

Как это отследить? В упор не видет модулей, хотя сам питон эти модули видет...

telefonist ( 2012-07-11 12:16:39 +0400 )редактировать

Может потому , что система не знает такого слова , как "видет" ?

zzuz ( 2012-07-11 12:57:41 +0400 )редактировать

Ладно издеваться, дайте лучше дельный совет. Наверняка дело в мелочи.

telefonist ( 2012-07-11 13:18:35 +0400 )редактировать

Когда автор не уважает людей , которые потенциально могут поделиться с ним знаниями , то это далеко не мелочь. Дельный совет тут простой - логи , книги ,настройки и эксперементы.

zzuz ( 2012-07-11 14:01:45 +0400 )редактировать

Простите, в чем выражено не уважение? Когда разберусь, выложу решение проблемы, нверняка не только у меня подобное случилось.

telefonist ( 2012-07-11 14:30:12 +0400 )редактировать

Уважаемый, пока от вас слышно "В огороде бузина, а в Киеве дядько.....", вы не указали ни что за дистриб, ни как пытаетесь ставить (из пакетов или исходников), ни на какие модули мат со стороны питона.

CheeZ ( 2012-07-11 14:50:17 +0400 )редактировать

Прошу извинить за неточности, пока вопрос запуска на 64битной платформе можно отложить. Я ее запустил на аналогичном 32-х битном дистрибе. Оба архлинуксы. Посмотрите ниже. Сейчас проблема в том что с астериском 1.6 оно работает, с 1.10 не хочет. Все астериски собраны из исходников, при этом сторонние морды типа freepbx fop прекрасно работают.

telefonist ( 2012-07-11 14:56:51 +0400 )редактировать
0

Дополнительно вопрос : с 10-м астериском оно работает или только с 1.6 - 1.8 ?

ссылка удалить спам редактировать

ответил 2012-07-11 14:31:58 +0400

telefonist Gravatar telefonist
61 16 6

Comments

Замечено следующее, к астериску 1.6.Х соединяется без проблем. Пробовал на разных машинах. К астеру 1.10 конектится но в логах орет сообщениями типа :

ERROR :: Server Server_1 :: Error Executting Command 'sip show peer 202', reason: Connection closed

и подобными. Хотя если верить дебагу, ответы от астериска приходят.

Куда копать ?

telefonist ( 2012-07-11 14:52:05 +0400 )редактировать

Скачанный с svn monast так же отказывается работать с 10-й версией астериска...

telefonist ( 2012-07-11 16:04:04 +0400 )редактировать

Похоже проблема как то связана с АМИ. в 1.8 и 1.10 разные версии интерфейса ?

telefonist ( 2012-07-11 16:39:23 +0400 )редактировать

Приятно видимо поговорить с умным человеком.

zzuz ( 2012-07-12 04:28:30 +0400 )редактировать

Ваш ответ

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
[скрыть предварительный просмотр]

Закладки и информация

Добавить закладку

подписаться на rss ленту новостей

Статистика

Задан: 2012-07-11 11:22:42 +0400

Просмотрен: 273 раз

Обновлен: Jul 11 '12

Похожие вопросы:

Проект компании "АТС Дизайн"
Asterisk® и Digium® являются зарегистрированными торговыми марками компании Digium, Inc., США.
IP АТС Asterisk распространяется под лицензией GNU GPL.